lunedì 14 novembre 2016

Risolvere il problema del browser e del dizionario in livecode 8 e 9

Finalmente è stato capito dove sia il problema che affliggeva livecode dalla versione 8 per quanto riguardava il browser e il dizionario su Linux.
Su questo sistema operativo, infatti, sia il dizionario che il widgert borwser rendevano inutilizzabile livecode.
Poichè entrambi sono basati su Chromium, l'utente Saa  ha scoperto che lo stesso bug affligge Steam su linux (che sia basato su livecode?) e gli utenti linux hanno trovato una soluzione. Prima di avviare livecode su linux, prima bisogna impostare le varabile LC_ALL e LC_NUMERIC su C.
In pratica, per lanciare livecode 8 o livecode 9 su linux, bisogna scrivere:

LC_ALL= LC_NUMERIC=C
/opt/livecode/livecodecommunity-9.0.0-dp-1.x86_64/livecodecommunity.x86_64


E tutto funzionerà perfettamente: